You are here

Horrible audio on TKR-820

I have been on and off battling this for a few weeks now. It's either too soft, too loud, overdriven, humming, whatever... So I dug into it this weekend and started ripping things apart. I also have  a Squelch board that I want to install, The squelch board uses discriminator audio to sence quieting and then give the controller a COR signal. The TKR-820 does not have a COR signal when the internal controller / signaling board is removed, at least none that I can find, I will still look into that. So I was using discriminator audio to the NHRC 3.1 controller, which uses a TS-64WDS tone encoder /decoder to sense a CTCSS tone, and output a signal if it is present. In my oversight I somehow failed to see, or failed to configure it to filter out 300Hz and below, to keep the tone out of the repeated audio. DUH!! So right now I have discriminator audio going to the controller as repeat audio. It’s emphasized, and passes audio below 300Hz. Hey, never said I was an expert, I am always learning!

So what I want to do now is to get that received audio out enabled on pin 10 of the 15 pin accessory plug. It is already has the -6db per octave de-emphasis and filtered below 300Hz to remove any CTCSS tones, and is suitable for repeat audio. When the Kenwood signaling board is installed the signaling board sends a signal to turn on the audio when there is a COR signal, basically when a RF signal is strong enough to break the internal squelch setting. I’ll have to check on the spare repeater if this pin is high or low when receiving a signal, then either ground or pull the pin high to allow the filtered RX audio to pass to the 15 pin accessory plug. I have to give credit to WD7F for pointing this out in his article that the filtered RX audio is switched by the COR signal. From what it seems, a lot of hams don't know this, and that a lot use the internal controller with a supplemental IDer to comply with regulations. I guess I could use the discriminator audio directly, but would have to add some buffers and make sure I de-emphasized, but for now I am going to use the filtered RX audio, and see how that works. I will post some updates when I have them.

73

KC2ZPK

Comments

One glitch I may run into, if I feed the de-emphasized audio into the controller I think it is also filtered. If there is a high pass filter on that audio I will loose the CTCSS tones going into the controller. I would have to split the audio on the discriminator to feed the CTCSS board and the squelch board. I might have to buffer that audio line before I split it so I don't lose too much audio level. 

On a positive note, grounding pin 7 on CN6 of the TX-RX board will turn on the filtered audio to pin 10 on the accessory plug. So I can use that  for repeat audio, the only glitch being the one I mentioned. Just have to wait and see...

73

KC2ZPK

Pages

Add new comment

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.
CAPTCHA
This question is for testing whether you are a human visitor and to prevent automated spam submissions.

Theme by Danetsoft and Danang Probo Sayekti inspired by Maksimer